Welcome, Guest
Username: Password: Remember me

TOPIC: 05 V70 window washers

05 V70 window washers 3 weeks 3 days ago #1329

My windshield and rear window washers are not working, headlight washer is working.
I couldn't see any fusses blown.
I moved the hose in the hood and disconnected at the wye, no fluid came out when trying to wash.
I can hear the pump working when headlights are washed but no pump noise for just the windshield.
Could the tank have crud in it and plugging up, or is there a separate pump for the front and back windows that is gone?
Any suggestions.
Ted
The administrator has disabled public write access.

05 V70 window washers 3 weeks 1 day ago #1334

  • gdill3
  • gdill3's Avatar
  • OFFLINE
  • Moderator
  • Posts: 387
  • Thank you received: 30
  • Karma: 2
wrote:
My windshield and rear window washers are not working, headlight washer is working.
I couldn't see any fusses blown.
I moved the hose in the hood and disconnected at the wye, no fluid came out when trying to wash.
I can hear the pump working when headlights are washed but no pump noise for just the windshield.
Could the tank have crud in it and plugging up, or is there a separate pump for the front and back windows that is gone?
Any suggestions.
Ted

This can be as simple as a loose hose or as not simple as a failing delivery valve. All it takes is one loose/corroded ground wire to spend big bucks and much time chasing non-fixes.

Gain access to the washer hoses and valves by removing the panel(s) covering the rear speakers. You can then disconnect the hoses and reverse-flush with compressed air or a hand pump from your futbol kit.

More info in the links below.

George Dill

tinyurl.com/nj8vge3

tinyurl.com/kx4zuqg

tinyurl.com/ko6k9u5
The administrator has disabled public write access.
Time to create page: 0.267 seconds

We have 154 guests and no members online