Welcome, Guest
Username: Password: Remember me

TOPIC: CEL won't go out (P0133) 1998 S70 (Base)

CEL won't go out (P0133) 1998 S70 (Base) 2 months 3 weeks ago #1375

  • Mr. Detail
  • Mr. Detail's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Greetings to all;
This is my first post as I am reaching out to whomever I can to help me resolve this issue.
I have dealt with this now for over 16 months and had to get an emissions waiver last summer.
I have already replaced the front oxygen sensor once and the rear one twice. Right now both sensors are O.E. Bosch with the complete wiring and plugs. I have replaced the air intake tube, PCV o-ring near the flame trap and the 90 degree elbow at the manifold near the power steering pump. Just dropped over $500 yesterday at an experienced Volvo mechanic similar to a dealer and after he replaced the rear sensor yet again, the light is back on. Now he tells me that the front sensor and the rear sensor are reading the same which is not normal. He said the rear should have a different readout and now he says I need a new cat convertor. ($1,000)
I can't take much more of this. I keep reading that this is most likely a vacuum leak problem but I haven't a clue where to begin looking. Any help or suggestions that will actually get to a resolution would be really nice. I have gone thru so many different mechanics including the dealer once last year. No one can truthfully fix this! Just keep throwing money at it and sooner or later the CEL will go out for good.
You must register to gain posting privileges.

CEL won't go out (P0133) 1998 S70 (Base) 2 months 2 weeks ago #1386

  • brick-a-brac
  • brick-a-brac's Avatar
  • OFFLINE
  • Administrator
  • Posts: 55
  • Thank you received: 5
  • Karma: 0
Have any of the technicians who worked on the car examined the vacuum tree near the IAC? Hoses there can deteriorate from heat, etc and can cause the conditions for a PO 133.

Keep us posted.
You must register to gain posting privileges.
Time to create page: 0.242 seconds

We have 128 guests and no members online

You are here: Home Forum FWD & AWD Forums S70, V70 & V70XC - (1998-2000) CEL won't go out (P0133) 1998 S70 (Base)